Jump to content United States-English
» Contact HP

HP Linux imaging and printing

Print, scan and fax drivers for Linux

   

» 

Home

» About HPLIP
» Screenshots
» Release information
» Licensing information
» Get help

Install and setup

» Download instructions
» Installation instructions
» Installation wizard
» Supported printers
» System requirements
Content starts here

System Requirements

HPLIP Version: 
Current Version
Printer(s): 
All
Linux OS Distribution(s): 
All
Notes: 

 

  • Linux kernel 2.4.19 and above (2.6.x recommended).
  • GNU software tools are required to build from source code. This includes the ANSI C compiler, ANSI C++ compiler and POSIX compliant environment.
  • libusb 0.1.8 or higher.
  • GPL Ghostscript 7.05 or higher.
  • Foomatic 3.0.2 or higher.
  • Qt 3.x or higher for UI toolkit.
  • PyQt 3.14 or higher for Qt wrapper for Python.
  • Python 2.2 or higher and python-devel (Python 2.3+ for fax support)
  • Reportlab (optional-provides fax cover page support)
  • CUPS 1.1.15 or higher and cups-devel.
  • libjpeg 6b or higher and libjpeg-devel.
  • net-snmp 5.0.9 or higher and net-snmp-devel for network support.
  • CUPS DDK 1.2 or higher for dynamic PPD support.
  • Python Imaging Library (optional-provides support for hp-scan)
  • Dbus version 0.80+ (optional-for fax and status support)