Jump to content United States-English
» Contact HP

HP Linux imaging and printing

Print, scan and fax drivers for Linux

   

» 

Home

» About HPLIP
» Screenshots
» Release information
» Licensing information
» Get help

Install and setup

» Download instructions
» Installation instructions
» Installation wizard
» Supported printers
» System requirements
Content starts here

Python 3 Limitations

HPLIP Version: 
3.15.2
Notes: 

 

Dependent package installation fails on Fedora

"yum" is the default package manager on Fedora distributions, which is not ported to support Python 3 by Fedora. Fedora has alternate plans for the package manager tool as can be seen in the linkhttp://fedoraproject.org/wiki/Changes/ReplaceYumWithDNF

At present, installation of dependencies for HPLIP fails in Python3 environment on Fedora distributions due to the above limitation. Till the time Fedora makes DNF available and HPLIP includes support for DNF, users will have to manually install the required dependencies for HPLIP as suggested below:

Run the below command in Python2 environment.

su -c "yum install cups cups-devel audit gcc-c++ ghostscript openssl-devel libjpeg-devel net-snmp-devel glibc-headers libtool libusb1-devel make python-imaging sane-backends sane-backends-devel sane-frontends xsane dbus-devel polkit polkit-gnome wget avahi-tools python3 python3-devel python3-PyQt4 python3-pyqt4-dbus python3-dbus avahi-tools python3-gobject python3-pip python3-pillow"

 

Cannot launch hp-toolbox on OpenSuse and Fedora

For all the opensuse versions lesser than 13.2 and Fedora versions less than 21, "hp-toolbox" cannot be launched.

hp-toolbox is dependent on the shared library "qt.so", which is not shipped with the package "dbus-1-python3" for Python versions less than 3.4.  All the functionalities provided by hp-toolbox work fine through the individual tools like hp-setup, hp-levels, etc.

This limitation is being followed up at,

https://bugzilla.novell.com/show_bug.cgi?id=843493

XSane installation failed message on Debian

During dependent package checks on Debian, HPLIP shows xsane installation has failed. This happens due to a tool "/sbin/gnome-menu-blacklist" which is invoked by the package manager tool apt-get is not ported to support Python3 yet.

In most cases, Xsane is installed but a <<< xsane install failure >>> message is displayed due to apt-get returning a non-zero status.

Continue the installation by typing 'n' when HPLIP tools ask to retry xsane installation.

This limitation is being followed up at,

https://tracker.debian.org/news/346436

Fax

HPLIP currently doesn't support Fax Cover Page in Python3 environments. For enabling Fax Cover Page in  HPLIP, check the official documentation of reportlab at:

http://www.reportlab.com/documentation/relnotes/30/